$txt['youtube'] = 'YouTube'; $txt['youtube_invalid'] = '#Invalid YouTube Link#'; Eskape New Battery... No Power

Author Topic: Eskape New Battery... No Power  (Read 2119 times)

0 Members and 1 Guest are viewing this topic.

Offline Larry

  • Mokai Hero Member
  • ****
  • Posts: 302
  • Location: Maryland
  • Cool Points: 24
  • Engine: Honda GC190
  • Model Year: 2007/2007
Re: Eskape New Battery... No Power
« Reply #15 on: July 15, 2018, 06:42:10 PM »
Had a couple of boats out for a shakedown run.  First boat was good.  Second ran fine up the river and for some fishing.  Then the kill switch stopped working.  Had to shut down with the key.  Later  when tried to restart - nothing at all.  Obviously electric problem.  I was only a hundred yards above the ramp so just paddled in.  Next morning found a bolt on the floor that held the regulator and several grounds.  One minute fix.
My kill switch doesn't work, always have to shut down with the key. What should I check ?

Offline Painlesstom

  • Painless Tom
  • Administrator
  • Mokai Maniac Member
  • *******
  • Posts: 5806
  • Age: 45
  • Location: Georgia
  • Cool Points: 59
  • Making Your Mokai... A Better Mokai!
    • Painless Products
  • Engine: EX21 w/17 head - ES
  • Model Year: 2003 / 2011 / 2015
Tom

  >:D    

_________________________

www.PainlessClutch.com

Offline bizler

  • Mokai Addict Member
  • *****
  • Posts: 574
  • Age: 76
  • Location: Vancouver, WA
  • Cool Points: 46
  • Engine: EX21 W/EX17 Head
  • Model Year: 2010
Re: Eskape New Battery... No Power
« Reply #17 on: July 15, 2018, 11:18:55 PM »
You might want to check the switch to see if the little E-clip on the end of the shaft has corroded and slipped off.  This allows the contact washer to ground out. On mine, the back just screws off allowing access to the inners.  Replace the E-clip on th plastic shaft and it will be good to go.  Use a stainless E-clip and it will last a lot longer.    ;)

Offline W00DENNICKEL

  • Newbie
  • *
  • Posts: 18
  • Age: 66
  • Location: Nashville, TN
  • Cool Points: 2
  • Engine: 21 w 17 head
  • Model Year: 2014 Es-Kape
Re: Eskape New Battery... No Power
« Reply #18 on: July 22, 2018, 10:48:35 PM »
I figured out the source of my "No Power" issue.
There appears to be an intermittent short in the steering servo wiring harness. Sometimes the ignition light comes on, sometimes it is dimly lit or not at all. A couple of times it blew the circuit breaker.
I also found a loose steering servo arm. The set screw is missing.
Does anyone have any third party sources to buy a replacement wiring harness and a servo arm set screw?
Thanks.
"Just because we're traveling down a well worn path it doesn't mean we're heading in the right direction"

Offline Painlesstom

  • Painless Tom
  • Administrator
  • Mokai Maniac Member
  • *******
  • Posts: 5806
  • Age: 45
  • Location: Georgia
  • Cool Points: 59
  • Making Your Mokai... A Better Mokai!
    • Painless Products
  • Engine: EX21 w/17 head - ES
  • Model Year: 2003 / 2011 / 2015
Re: Eskape New Battery... No Power
« Reply #19 on: July 22, 2018, 11:45:57 PM »
Mokai makes their wiring harness, probably why there are so many issues with it... If you want a new harness you'll have to make it yourself or contact them to see it they will warranty yours. Don't know what thread the set screw is, but I will pull one out of one of the servos I have laying around and let you know.
Tom

  >:D    

_________________________

www.PainlessClutch.com